Welcome to the BEAM Forum!

We encourage you to sign in our forum and participate in the BEAM community. The forum is maintained by the BEAM project team who will most likely answer your questions within 24 hours (except during common holidays) - if not done by other community members. Collaborate, share your knowledge and learn from other users!

If you don't find what you are looking for, please also consider the following external forums:

Combination View Flat View Tree View
Threads [ Previous | Next ]
gpt Error: Null, when using Meris.N1Patcher over an ICOL2.9 with cloud mask
toggle
gpt Error: Null, when using Meris.N1Patcher over an ICOL2.9 with cloud mask
error message gpt icol n1patcher
5/14/12 11:31 AM
Dear Forum,

I received and "error: Null". when I tried to save the result of my gpt graph back to ENVISAT N1 format. My source image is a MERIS L1b FSG product in ENVISAT N1 format. I am using the Correct Radiometry first to Equalize and Smile Correct my images, then I run ICOL2.9 using a using a cloud mask and as input the node results of correct radiometry, and I am trying to save the end product back to ENVISAT N1 format using the Meris.N1Patcher. If I omit the N1Patcher and save the end result as a BEAM-DIMAP format I received no errors. The errors are raised when I try to save it back to N1Patcher. If I omit the ICOL node, I can save the results with no problem with the ENVISAT N1 format. If I run the ICOL node alone I have the same problem.


Here is the call to the GPT and the xml graph is attached. The output that I got follows bellow, and the gpt graph is attached.


/
 1home/jose/beam-4.10/bin/gpt.sh /home/jose/EOData3/scripts/gpt/current_gpt_graph.xml -SsourceProd=/home/jose/EOData3/Instrument/MERIS/V3/L1B/FSG/MER_FSG_1PNEPA20080725_092241_000000252070_00351_33471_3811.N1 -ScloudMaskProduct=/home/jose/EOData3/cloud_prob/V3_cloud_prob_MER_FSG_1PNEPA20080725_092241_000000252070_00351_33471_3811.nc
 2
 3
 4SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
 5SLF4J: Defaulting to no-operation (NOP) logger implementation
 6SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
 7Error: Could not load mediaLib accelerator wrapper classes. Continuing in pure Java mode.
 8Occurs in: com.sun.media.jai.mlib.MediaLibAccessor
 9com.sun.media.jai.mlib.MediaLibLoadException
10kernel sum = 0.08745136
11kernel sum = 0.08745136
12kernel sum = 0.8996342
13kernel sum = 0.8996342
14x, y = 73,101
15x, y = 73,101
16
17Error: null


Any hints? or advice? Is it a bug?
Flag Flag
I have the same problem within BEAM4.10. Not using the gpt call at all. Just a simple ICOL processing with the output format as ENVISAT N1.
A screen shoot of the error message in beam is attached.
Thanks for your help,

Jose
Attachment

Attachments: Selection_078.png (37.7k)
Flag Flag
Hi Jose, did you really attach the graph XML etc.?
Flag Flag
Dear Jose,

it seems that from your preprocessing chain (equalize, smile etc.) you have additional bands in the FSG input product which the N1 patcher does not correctly take into account. Could you provide me your input product for testing, or at least give me a list of all bands and tie point grids in this product? - I just tried the N1 patcher with a 'normal' L1b input product, which has the input bands 'radiance_n' (n=1,...,15), l1_flags, and detector_index. In this case, it works fine.

Thanks,
Olaf
Flag Flag
Dear Olaf,

I have shared a dropbox folder with the source image, cloud mask and xml graph. Let me know if you got it.
Thanks!

Jose
Flag Flag
It seems that it did not went correctly. But I have shared a dropbox folder with the graph and the source image.
Thank you for looking at this issue.

Jose
Flag Flag
Dear Jose,

thanks for the sources. I found and fixed this problem. Then I checked your example, it worked fine with both Visat and gpt command line. A new version of ICOL (v2.9.1) is available for installation, please see Module Manager --> Module Updates in BEAM/Visat. - Please let us know if you still observe any problems.

Thanks and best regards,
Olaf
Flag Flag
RE: gpt Error: Null, when using Meris.N1Patcher over an ICOL2.9 with cloud
icol
5/16/12 11:09 AM as a reply to Olaf Danne.
Dear Olaf,

Thank you ! the problem has been fixed. And I saw as well that this fix did not dropped AMORGOS correction bands. emoticon

Although, ICOL still have a previously reported issue that if I display and save the request file, ii only displays and saves the default options. Not the ones that a user might have changed.

Cheers!

Jose
Flag Flag
Dear Jose,

Jose M. Beltran:
Dear Olaf,

Although, ICOL still have a previously reported issue that if I display and save the request file, ii only displays and saves the default options. Not the ones that a user might have changed.

Jose


I fixed this issue as well, it will come with the next ICOL update. If you find further issues in the meantime, please let us know...

Cheers,
Olaf
Flag Flag