Welcome to the BEAM Forum!

We encourage you to sign in our forum and participate in the BEAM community. The forum is maintained by the BEAM project team who will most likely answer your questions within 24 hours (except during common holidays) - if not done by other community members. Collaborate, share your knowledge and learn from other users!

If you don't find what you are looking for, please also consider the following external forums:

Combination View Flat View Tree View
Threads [ Previous | Next ]
RE: Problem reprojecting data
toggle
Problem reprojecting data
7/23/15 11:36 AM
I have a problem reprojecting data from the Diversity II project, http://www.diversity2.info/.

I've tried both BEAM VISAT and using a script. I've tried 2 different computers. I've got the latest version of both BEAM and JRE.

Attached you will find 3 products:
1 old product, Lake-Abaya, and I have no problem reprojecting it.
2 new products (created 2015-06 or later), and I can't reproject any of them.

In the attached file you will find the settings I used. Below you will find the error messages I get.



--- Error message in BEAM VISAT ---
An internal error occurred during the target product initialisation.
Type: NullPointerException
Message: null


--- Error message when scripting ---

java.lang.NullPointerException
at org.esa.beam.framework.gpf.internal.OperatorContext.convertOperatorCo
ntextToMetadata(OperatorContext.java:549)
at org.esa.beam.framework.gpf.internal.OperatorContext.initGraphMetadata
(OperatorContext.java:540)
at org.esa.beam.framework.gpf.internal.OperatorContext.initializeOperato
r(OperatorContext.java:489)
at org.esa.beam.framework.gpf.internal.OperatorContext.getTargetProduct(
OperatorContext.java:266)
at org.esa.beam.framework.gpf.Operator.getTargetProduct(Operator.java:32
3)
at org.esa.beam.framework.gpf.main.CommandLineTool.runOperator(CommandLi
neTool.java:260)
at org.esa.beam.framework.gpf.main.CommandLineTool.runGraphOrOperator(Co
mmandLineTool.java:238)
at org.esa.beam.framework.gpf.main.CommandLineTool.run(CommandLineTool.j
ava:149)
at org.esa.beam.framework.gpf.main.CommandLineTool.run(CommandLineTool.j
ava:122)
at org.esa.beam.framework.gpf.main.GPT.run(GPT.java:54)
at org.esa.beam.framework.gpf.main.GPT.main(GPT.java:34)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.bc.ceres.launcher.Launcher.launch(Launcher.java:154)
at com.bc.ceres.launcher.Launcher.main(Launcher.java:56)

Error: java.lang.NullPointerException
Attachments: 20150723_WebGIS_iw_10y.zip (2,326.3k)
Flag Flag
RE: Problem reprojecting data
7/23/15 11:57 AM as a reply to Niklas Hahn.
Hi Niklas,

could you please try again using the latest development snapshot of BEAM? You can obtain it here.

Cheers,
Thomas
Flag Flag
RE: Problem reprojecting data
7/23/15 2:56 PM as a reply to Thomas Storm.
Thanks a lot Thomas!

Updating to the latest development snapshot of BEAM solved the problem.
Flag Flag