Welcome to the BEAM Forum!

We encourage you to sign in our forum and participate in the BEAM community. The forum is maintained by the BEAM project team who will most likely answer your questions within 24 hours (except during common holidays) - if not done by other community members. Collaborate, share your knowledge and learn from other users!

If you don't find what you are looking for, please also consider the following external forums:

Combination View Flat View Tree View
Threads [ Previous | Next ]
Case Regional Processor
toggle
Case Regional Processor
3/31/15 1:08 PM
Hi,

I´m running Case-2 processor and spatial subset for several MERIS images using batch mode and XML file through the cmd prompt. For some reason, only less than a half of the images that I have in the folder are correctly processed. Nothing is done to rest of the images, and the following error appears in the cmd screen:


Error: null

SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further detail
s.
java.lang.NullPointerException
at com.bc.ceres.core.VirtualDir.create(VirtualDir.java:101)
at org.esa.beam.dataio.landsat.geotiff.LandsatGeotiffReaderPlugin.getInp
ut(LandsatGeotiffReaderPlugin.java:144)
at org.esa.beam.dataio.landsat.geotiff.LandsatGeotiffReaderPlugin.getDec
odeQualification(LandsatGeotiffReaderPlugin.java:50)
at org.esa.beam.framework.dataio.ProductIO.getProductReaderForInput(Prod
uctIO.java:253)
at org.esa.beam.gpf.operators.standard.ReadOp.initialize(ReadOp.java:73)

at org.esa.beam.framework.gpf.internal.OperatorContext.initializeOperato
r(OperatorContext.java:438)
at org.esa.beam.framework.gpf.internal.OperatorContext.getTargetProduct(
OperatorContext.java:218)
at org.esa.beam.framework.gpf.Operator.getTargetProduct(Operator.java:30
6)
at org.esa.beam.framework.gpf.graph.NodeContext.initTargetProduct(NodeCo
ntext.java:74)
at org.esa.beam.framework.gpf.graph.GraphContext.initNodeContext(GraphCo
ntext.java:189)
at org.esa.beam.framework.gpf.graph.GraphContext.initNodeContext(GraphCo
ntext.java:172)
at org.esa.beam.framework.gpf.graph.GraphContext.initNodeContext(GraphCo
ntext.java:172)
at org.esa.beam.framework.gpf.graph.GraphContext.initNodeContext(GraphCo
ntext.java:172)
at org.esa.beam.framework.gpf.graph.GraphContext.initNodeContext(GraphCo
ntext.java:172)
at org.esa.beam.framework.gpf.graph.GraphContext.initOutput(GraphContext
.java:156)
at org.esa.beam.framework.gpf.graph.GraphContext.<init>(GraphContext.jav
a:85)
at org.esa.beam.framework.gpf.graph.GraphContext.<init>(GraphContext.jav
a:58)
at org.esa.beam.framework.gpf.graph.GraphProcessor.executeGraph(GraphPro
cessor.java:123)
at org.esa.beam.framework.gpf.main.DefaultCommandLineContext.executeGrap
h(DefaultCommandLineContext.java:79)
at org.esa.beam.framework.gpf.main.CommandLineTool.executeGraph(CommandL
ineTool.java:528)
at org.esa.beam.framework.gpf.main.CommandLineTool.runGraph(CommandLineT
ool.java:370)
at org.esa.beam.framework.gpf.main.CommandLineTool.runGraphOrOperator(Co
mmandLineTool.java:278)
at org.esa.beam.framework.gpf.main.CommandLineTool.run(CommandLineTool.j
ava:148)
at org.esa.beam.framework.gpf.main.CommandLineTool.run(CommandLineTool.j
ava:124)
at org.esa.beam.framework.gpf.main.GPT.run(GPT.java:47)
at org.esa.beam.framework.gpf.main.GPT.main(GPT.java:34)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.bc.ceres.launcher.Launcher.launch(Launcher.java:154)
at com.bc.ceres.launcher.Launcher.main(Launcher.java:56)

Error: null



When looking at the images that were not corrected, they don't seems to have any problem. Moreover, when I tried to correct them manually through the software, the correction is applied.

Any ideas?

Thanks,
Watch Ex Machina Online
Flag Flag
RE: Case Regional Processor
3/31/15 3:50 PM as a reply to steve gleeson.
Hi Steve,

your stacktrace shows me that you don't have the latests versions of several modules.
Can you use the Module Manage () to get the latest updated and try again please? Maybe this will already solve the problem.

kind regards
Marco
Flag Flag